Réseaux‎ > ‎Cisco‎ > ‎

Exemple: Serveur VPN PPTP avec PAT


1. Résumé des fonctionnalités de cette configuration

  • Le routeur joue le role d'un concentrateur VPN en PPTP (fonctionne avec un IOS de base, les fonctionnalités 3DES sont inutiles)
  • Le routeur fait aussi du NAT (du PAT en réalité) entre son interface LAN (adressage en IP privé) et Internet (adressage en IP publique)
  • Les clients PPTP (configuration standard sous Windows XP par exemple) récupèrent une adresse IP par le routeur, dans un subnet IP différent de celui du LAN

2. Tableau des variables utilisées


Description
Varibale
Exemple
Optionelle
Adresse IP de l’interface LAN de ce routeur (en /24)
IP-LAN 192.168.1.254 NON
Adresse IP du réseau de l'interface LAN
IP-NET-LAN
192.168.1.0
NON
Adresse IP de l'interface INTERNET
IP-INTERNET
82.10.10.1
OUI (utilisation de DHCP)
Maque IP de l'interface INTERNET
MASK-INTERNET
255.255.255.0
OUI (utilisation de DHCP)
Passerelle INTERNET
IP-GW-INTERNET
82.10.10.254
OUI (utilisation de DHCP)
Adresse IP du réseau virtuel pour les clients VPN (en /24)
NET-VPN 192.168.2.0 NON
Adresse IP de l'interface virtuelle LAN du routeur
IP-PPTP
192.168.2.1
NON
Première adresse du pool des adresses Virtuelles VPN
VPN-FIRST 192.168.2.2 NON
Dernière adresse du pool des adresses virtuelles VPN
VPN-LAST 192.168.2.254 NON
Adresse IP du serveur DNS du LAN IP-DNS-LAN 192.168.1.1 OUI
Adresse IP du serveur WINS du LAN IP-WINS-LAN 192.168.1.2 OUI
Login d’un compte utilisateur
LOGIN-USER1 boyo
NON
Mot de passe d’un compte utilisateur PASSWORD-USER1 boyopass
NON

Dans l'exemple suivant, l'interface "Ethernet 0" est celle connectée au LAN, et l'interface "Ethernet 1" est celle connectée à Internet.

3. Configuration

!

username LOGIN-USER1 password PASSWORD-USER1

!

aaa new-model

aaa authentication ppp default local

aaa authorization network default local

!

!

vpdn enable

!

vpdn-group PPTP

accept-dialin

protocol pptp

virtual-template 1

!

async-bootp dns-server IP-DNS-LAN

async-bootp nbns-server IP-WINS-LAN

!

!

!

interface Ethernet0

ip address IP-LAN 255.255.0.0

ip nat inside

no shut

!

interface Ethernet1

ip address IP-INTERNET MASK-INTERNET

ip nat outside

no shut

!

interface Virtual-Template1

ip address IP-PPTP 255.255.255.0

peer default ip address pool Pool-For-Vpn-Client

ppp encrypt mppe auto required

ppp authentication ms-chap ms-chap-v2

no shut

!

ip local pool Pool-For-Vpn-Client VPN-FIRST VPN-LAST

ip route 0.0.0.0 0.0.0.0 IP-GW-INTERNET

!

ip nat inside source route-map NoNat interface Ethernet1 overload

!

!

ip access-list extended No-Nat-Vpn-Client

deny ip IP-NET-LAN 0.255.255.255 NET-VPN 0.0.0.255

permit ip IP-NET-LAN 0.255.255.255 any

!

route-map NoNat permit 10

match ip address No-Nat-Vpn-Client

!

end
Comments